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Tutorial dataset

Please download the following two datasets:

https://github.com/Slicer/SlicerDataloadingAndVisualizationTut
orial/raw/main/VisualizationTutorial HeadScene.mrb
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https://github.com/Slicer/SlicerDataLoadingAndVisualizationTutorial/raw/main/VisualizationTutorial_HeadScene.mrb
https://github.com/Slicer/SlicerDataLoadingAndVisualizationTutorial/raw/main/VisualizationTutorial_HeadScene.mrb

Main user interface

% 3D Slicer 5.0.2

*} Welcome to Slicer >, -. a o_

Modules: 4

@ Add Data [ocu] Add DICOM Data

£3 mstall Sticer Extensions € pownload Sample Data

@ Customize Slicer E.,__ Explore Added Data

~ Feedback

Share your stories with us on the Slicer forum and let us know
"~ about how 3D Slicer has enabled your research.

We are always interested in improving 3D Slicer, to tell us about your problem or
submit a bug report, open Help -> Report a Bug.
> About

» Documentation &

» Acknowledgment

~ Data Probe: D:/data/PerkLabBootcamp/...utorial_HeadScene.mrb

Show Zoomed Slice

@ Data pro be B: T1 MRI
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Load sample MRI data

B 3D Slicer 5.0.2 ] X

File Edit view Help
% - [ ; =
ﬁ Modules: 4 | g} Welcome to Slicer v | - F‘E

N

B hE- Bwh - @A

'5: 0.0000mm = 140

Add Data ﬁ Add DICOM Data
B Install Slicer Extensions O Download Sample Da J-
# Customize Slicer = explore Added Da ™
~ Feedback

Share your stories with us on the Slicer forum and let us know
" about how 3D Slicer has enabled your research.

We are always interested in improving 3D Slicer, to tell us about your problem or 1 A: 0.0000mm = v HF O ¢ {_f ' R.: 0.0000mm

submit a bug report, open Help -> Report a Bug.
b About

b Documentation & Tutorials

b Acknowledgment

~ Data Probe

Show Zoomed Slice




Load sample MRI data

[ 3D Slicer 5.0.2 - ] X

File Edit View Help
o i
Modules: 4 Sample Data

([

b Help & Acknowledgement

* Builtin

Az 0.0000mm

DTIBrain

= [ =———F—— Rr:0.0000mm

~ Data Probe

Show Zoomed Slice




Load sample MRI data

% 3D Slicer 5.0.2 — O X

File Edit View Help

@ Modules: 4 hWeIcome to Slicer v -' \) ‘() E;_:;
@ o
(3.
A » J 1
(4
s N

i The axial, sagittal, and

Add Data Add DICOM Data
Install Slicer Extensions € pownload sample Data o o
o — coronal views automatically

~. | show the loaded volume

Share your stories with us on the Slicer forum and let us know
" about how 3D Slicer has enabled your research. B: MRHead

We are always interested in improving 3D Slicer, to tell us about your problem or
submit a bug report, open Help -> Report a Bug.
» About

» Documentation & Tutorials

» Acknowledgment

~ Data Probe

Show Zoomed Slice

B B: MRHead B: MRHead
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Adjust window/level

% 3D Slicer 5.0.2
File Edit View Help

@ Modules: 4 | #f% Sample Data v —' G' O E.,_E

® )

» Help & Acknowledgement

¥ Builtin

Switch to window/level
mouse mode

B: MRHead

R: 3.4452mm

~ Data Probe

Show Zoomed Slice

B: MRHead

F
B: MRHead

Load finished
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Adjust window/level

(B 3D Slicer 5.0.2

File Edit View Help

o s
@ Modules: ', | #% Sample Data

&

b Help & Adknowledgement

* Builtin

Adjust window/level
(brightness/contrast)
using the left mouse

1 button on a slice view
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Switch back to view/transform mode

- O X

B 3D Slicer 5.0.2
File Edit View Help

-=-Q EPO @« . 4 E:_%ﬁvz-v B e S - @2

i

o, B
@ Modules: Sample Data
2 5 -10.2

&

b Help & Adknowledgement

* Builtin

{1 ' R: 3.4452mm

A1 6.9286mm = ¥ R[] ¢

~ Data Probe

Show Zoomed Slice

B: MRHead

B: MRHead




Maximize view

B 3D Slicer 5.0.2

File Edit View Help

@ Modules:

C
b Help & Adknowledgement

* Builtin

~ Data Probe

Show Zoomed Slice

. | #% Sample Data

Click on the
maximize view
button

DTIBrain

I‘E‘: pg.-»--

B: MRHead B: MRHead

R 3.4452mm
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Slice view options

& 3D Slicer 5.0.2 - 0o x

File Edit View Help

@ Modules: 4 | % Sample Data - _' Q_ \h) \\\\\\ A
R

&

b Help & Adknowledgement

the pin icon to display the slice
view toolbar

in
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Slice view options

B 3D Slicer 5.0.2 - ] X

File Edit View Help

@ Modules: 4 | o Sample Data ot _' Q' -> F._E W o ‘% & Eﬁ' b F - gl-'.' e :@' - Dg - g "'
(% ER ; 1S -10,2143mm

b Help & Adknowledgement

* Builtin

Once the slice
viewer toolbar is
shown, click on the
ll>>”

DTIBrain

~ Data Probe

Show Zoomed Slice

B B: MRHead
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Show ruler

|

File Edit View Help

@ Modules: 4 Sample Data - _' 0 )] Fa_

|
€
c
i

] & & H 0 N Y B R Fa - B34
.-”% [~ R W@ " i 5: -10.2143mm
= € “5) 4+ w| Axial v < @ H‘J % u \ |
b Help & Adknowledgement = ) : : ’ : : .‘ND ruler

e i MNone
* Builtin

Thick

0.00 |*| [ | none ® \White ruler T
Black ruler
MRHead Yellow ruler

DTIBrain

~ Data Probe

Show Zoomed Slice




Rotate to volume plane

% 3D Slicer 5.02 — O X

File Edit View Help

@ @ Modules: 4 | g Welcome to Slicer > -. 3 O

@

f@ Add Data Add DICOM Data

Betmoee [ O 16 | Often, MRI volumes are not
48 customize Slicer {= Explore Added Data . .
axis-aligned. To show the true
TR B I axial view, click the ‘Rotate to

"~ about how 3D Slicer has enabled your research.

)
We are always interested in improving 3D Slicer, to tell us about your problem or vo I u m e p I a n e b u tt O n ]

submit a bug report, open Help -> Report a Bug.

~ Feedback

» About

» Documentation & Tutorials

e Note: This image will not be
affected, but many DICOM MR
images need to be aligned.

~ Data Probe

Show Zoomed Slice

L
E
B
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Switch to conventional layout

B 3D Slicer 5.0.2

File Edit View Help
o s
Modules: 4 Sample Data

&

b Help & Adknowledgement

* Builtin

DTIBrain

~ Data Probe

Show Zoomed Slice

B b E- B

Conventional Widescreen
@ Conventional Plot
Four-Up
Four-Up Table
E Four-Up Plot
E Four-Up Quantitative
Dual 3D
Triple 30
3D only
[E] 3D Table
m Flot only
D Red slice only
E Yellow slice only
E Green slice only

Tabbed 30
ﬁ Tabbed slice

' E Compare

m Compare Widescreen
E Compare Grid

E Three over three

E Three over three Plot
ﬁ Four over four

Bﬂ Two over two

m Side by side

ﬁ Four by three slice
m Four by two slice

@ Three by three slice

i

O

X

-“‘!' EF




Link views

(% 3D Slicer5.0.2

- O X
File Edit View Help
@ Modules: 4 | o Sample Data hd -' 0' d E._E @ 0 ‘% & b F - El".‘ e E@' -—%* - ’-t.'f - P
b Help & Adknowledgement =
* Builtin

After linking views, if any

setting is changed ina 2D
view, all others follow.

5:-10.2143mm = G @ A:6.9286mm = ¥ @ ) =———=F——— R:3.4452mm
u'Axial'%WHA%EP‘I&'

ﬂ MNone ¥

CTACardio DTIBrain

0.00 | m None v

MRHead

~ Data Probe

Show Zoomed Slice
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Show slices in 3D

(B 3D Slicer 5.0.2 - ] X
File Edit View Help

@ Modules: 4 | o Sample Data ot -' @' 0 E._E : A b F - El"_‘ E e E@' -—%* - ’-t.'f - P
&

b Help & Adknowledgement

Now the slice views are
linked. If you click the
‘Toggle slice visibility in
3D view’ button, then all
slices will show up.

A:6.9286mm = ¥ @ ] =———=F——— R:3.4452mm

* Builtin
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Show slices in 3D

(B 3D Slicer 5.0.2

File Edit View Help

o s
@ Modules: ', | #% Sample Data

&

b Help & Adknowledgement

* Builtin

DTIBrain

~ Data Probe

Show Zoomed Slice

N E-R B M R

AN AR Z al®™

All three anatomical slices
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Navigating the 3D view

(5 3D Slicer5.02 - o x

File Edit View Help

A = g = T s

@ Modules: 4 | o Sample Data - -' 0' d E‘E wew o
C .
b Help & Adknowledgement =

* Builtin

"1 Use the left mouse button to
'3l rotate, and the right mouse
button to zoom in and out

~ X A
O: IIRIeac £

B: MRHead
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Close the scene

B 3D Slicer 5.0.2

Edit View Help
d Data Ctrl+0 |
d DICOM Data

ecent L
Download Sample Data
"ﬁ Save Data

DTIBrain

~ Data Probe

Show Zoomed Slice

B: MRHead

S E-be BaA +-u- @O

= vy i [ =——{F—— R: 3.4452mm

B: MRHead
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Part 2:
3D visualization of surface models
of the brain
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Load tutorial scene

| = | VisualizationTutorial — O *

- Home Share View b e

u <« Per., » Visuali..

Drag and drop the file

A VisualizationTutorial_HeadScene.mrb
B Desop into Slicer, then click OK
=| Documents
; Downloads
D Music (B Add data into the scene 7 X
[=] Pictures v |Choose Directory to Add || Choose File(s) to Add | Show Options
litem  1item selected 33.6 MB v File Description

¥ D:/fdata/PerkLabBootcamp,VisualizationTutorial VisualizationTutorial_HeadScene.mrb MRE Slicer Data Bundle +
about how 3D Slicer has enabled your research. S

We are always interested in improving 3D Slicer, to tell us about your problem
submit & bug report, open Help -> Report a Bug.

b About

¥ Documentation & Tutorials

¥ Acknowledgment

* Data Probe

Show Zoomed Slice

B Reset
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Center view

% 3D Slicer 5.02 — O X

File Edit View Help

@ @ Modules: -4 | E Welcome to Slicer - -. a

@

@mmu [ocu] Add DICOM Data CliCk On the Sma” bOX
e R e | icon to center the
view, in 3D orin 2D

Share your stories with us on the Slicer forum and let us know
"~ about how 3D Slicer has enabled your research.

We are always interested in improving 3D Slicer, to tell us about your problem or
submit a bug report, open Help -> Report a Bug.
> About

» Documentation & Tutorials

» Acknowledgment

~ Data Probe

Show Zoomed Slice

: B: T1 MRI
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Explore loaded data

% 3D Slicer 5.0.2

File Edit View Help

@ @ Modules: 4

@

@ Add Data
Install Slicer Extensions

@' Customize Slicer
~ Feedback

Share your stories with
" about how 3D Slicer has

We are always interested in improving 3{
submit a bug report, open Help -> Rep
> About

» Documentation & Tutorials

» Acknowledgment

~ Data Probe

a Welcome to Slice @
£3 Add DICOM Data h

Markups

€D Models

e Scene Views

A. Segment Editor

@ Segmentations

4 Transforms

View Controllers

. Volume Rendering

@ volumes

a Welcome to Slicer
Wizards
Informatics
Registration
Segmentation
Quantification
Diffusion
Filtering
Surface Models
Converters
Endoscopy
Utilities
Developer Tools
Legacy
IntensityTransform
MultiVolume Support

Sequences

Show Zoomed Slice

DR 2

You can use the
module list, or the
favorite module
toolbar to switch to
the Data module

B: T1 MRI

B: T1 MRI

X

Bamn +-- @@
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Explore loaded data

(% 3D Slicer 5.0.2 — O X
File Edit View Help

@ @ Modules: 4 EDBE %) -' G_ @ E—TE e o ‘% 4’- k ‘ F > E'S‘ e .&’ ‘%“ w: Q w. a ﬁ

B e
e The Data module shows all the data in the scene.

Subject hierarchy Transform hierard'!y | All node§

Node
~ Scene
@ TivRI
@ T2MRI
~ [ Models
@ skul
€ left cerebral white matter
@ right cerebral white matter

The data items (“nodes”) can be shown/hidden,
renamed, deleted, cloned, etc.

@ right cerebellar white matter
left cerebellar white matter
left eyeball

@ right eyeball

@ right optic tract

left optic nerve
optic chiasm

€ right optic nerve
@ left optic tract
skin

Hide the ‘skin” model by clicking the e

~ Data Probe: D:/data/PerkLabBootcamp/...torial_HeadScene.mrml

ye icon.

-y

LY
\

V' Show transforms Show MRML ID's
» Subject hierarchy item information

Filter: |
» MRML node information

Show Zoomed Slice

L
F
B

@ @ Laboratory for Percutaneous Surgery — Copyright © Queen’s University, 2022 -25-




Foreground image

@ 3D Slicer 5.0.2
File Edit View Help
bR Bl SR vowes 4 oo =00 E B 4

@ 3D S

» Help & Acknowledgement

Subject hierarchy \ Transfonnhiera'd!y | All nodes |

Node
¥ Scene
@ TiMRI
@ T2vRI
~ [0 Models
@ skull
@ left cerebral white matter
@ right cerebral white matter
@ right cerebellar white matter
@ left cerebellar white matter
© left eyeball
@ right eyeball
@ right optic tract
€ left optic nerve
@ optic chiasm
€ right optic nerve

‘ﬁ/& Images can be overlaid (“fused”)

9 o s ) ron e g1 \\'| by setting the foreground image.
e Select ‘T2 MRI’ as foreground

N M * Adjust foreground opacity

: using the slider
B \\\

@ @F Laboratory for Percutaneous Surgery — Copyright © Queen’s University, 2022 -26 -

EEEEEEEEEEEEL . 0k

BEEHEREEHEEEEEORE ‘9

» Subject hierarchy item information

Filter: |
» MRML node information

~ Data Probe




Create folder

(% 3D Slicer 5.0.2 - o x

File Edit View Help

@ @ Modules: 4 | EE Data - _. c' O E-?E
;

» Help & Acknowledgement

4 ME- Bk - @

Subject hierarchy Transform hierarchy All nodes

Expand tree to level...

Create new subject

@ right cerebellar white matter
@ left cerebellar white matter
@ left eyeball

@ right eyeball

@ right optic tract

@ left optic nerve

@ optic chiasm

€ right optic nerve

@ left optic tract

@ skin

Right-click the scene (or the
empty area on the bottom), then
choose ‘Create new folder’.

(9993999999

V| Show transforms Show MRML ID's

» Subject hierarchy item information

Filter:
» MRML node information

~ Data Probe: D:/data/PerkLabBootcamp/...torial_HeadScene.mrml

Show Zoomed Slice
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Context menu actions

5 3D Slicer 5.0.2 -

P For list of “subject hierarchy” options for a

® | certain node, right-click it in the list. Note that

» Help & Acknowledgement

el the options are different for each node type.

Node
@ TivRI
@ 2R
¥ _ Models

© skull
€ left cerebral white matter
€ right cerebral white matter
right cerebellar white matter
€ left cerebellar white matter
© left eyeball
@ right eyeball
€ right optic tract
© left optic nerve
@ optic chiasm
@ right optic nerve
@ left optic tract
© skin

B NewFolder

Right-click the just created folder ‘NewFolder’.

- =

HEEEHEEEEBEB

H I FIIIIIFIIIY

Rename
V' Show trans Clone

» Subject hier Delete

Filter: l Convert models to segmentation node
» MRML node 1 Create child folder
Convert folder to subject
~ Data Probel
l Convert folder to study
Show Zoomed Slice

L
E
B
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Rename folder

5 3D Slicer 5.0.2 = = <
File Edit View Help

@ @ Modules: 4 EData - -. c. O E-_i
;

» Help & Acknowledgement

4 ME- Bk - @B

Subject hierarchy | Transform hierarchy All nodes

Node
@ TivRI
@ 2R
¥ _ Models

© skull
€ left cerebral white matter
€ right cerebral white matter
right cerebellar white matter
€ left cerebellar white matter
© left eyeball
@ right eyeball
€ right optic tract
© left optic nerve
@ optic chiasm
@ right optic nerve
@ left optic tract
© skin

B NewFolder

3939999999900 000Ey”
2

EEEREEEEEEEEEED

Rename
V' Show trans

» Subject hier Delete

s \ , ; ‘ : 2

Filter: l Convert models to segmentation node |
» MRML node 1 Create child folder J
= Convert folder to subject :
== jesdbealill Choose the Rename option and
Show Zoomed Slice

L rename the volume to ‘White matter
models’
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Select multiple nodes

% 3D Slicer 5.0.2 ~ - =
File Edit View Help

A B BR  Moddess 4 |Eoata =00 EPO & i 4 NP I m fa b-n- @A
Q_; 1

» Help & Acknowledgement

Subject hierarchy | Transform hierarchy All nodes

Nwecnmru ‘ff = ;
- A — : Se
e A Click ‘left cerebral white matter’,

* left cerebral white matter

* right cerebral white matte;

* right cerebellar white matte.

left cerebellar white matter

© left eyeball
@ right eyeball
@ right optic tract
© left optic nerve
@ optic chiasm
@ right optic nerve
@ left optic tract
© skin
7 White matter models

hold down Shift, and click ‘left
cerebellar white matter’.

309 99 9 9 9 9 9Na
HEEEBHEHEB

Note: You can use Control/Cmd
button to select individually.

» MRML node information “‘; «" & ¢ . ’ *Ey

~ Data Probe

V| Show transforms Show MRML ID's

» Subject hierarchy item information

Show Zoomed Slice

L
E
B
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Move nodes to folder

(% 3D Slicer 5.02 — O X

File Edit View Help
@ @ Modules: E- Data v -. G_ O E "f‘* v ‘Q‘ v g F
1

@

» Help & Acknowledgement

kF'a"‘ Ekb&;

Subject hierarchy Transform hierarchy All nodes

Node
@ TiMRI
¥ T2mr1
~ _ Models
© skull
*  left cerebral white matter
* right cerebral whit= matter G
* right cerebellar vite matter
*  left cerebellar w gatter
© left eyeball
@ right eyeball
@ right optic tract
© left optic nerve
@ optic chiasm
@ right optic nerve
@ left optic tract
@ skin
|.: White matter models

s eRE!
T E B @

B: T1 MRI

HEEEBHEHEB

3099999995

V| Show transforms Show MRML ID's

» Subject hierarchy item information

Filter:
» MRML node information

~ Data Probe

Show Zoomed Slice

B B: T1 MRI
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Hide all nodes in folder

(% 3D Slicer 5.0.2 - o x

File Edit View Help
@ @ Modules: E- Data v - G_ O E:f—_ ’é‘* v ‘Q‘ v a ﬁ
1 —_—

@

» Help & Acknowledgement

‘({' kF"'-‘ Ekb&

Subject hierarchy Transform hierarchy All nodes
Node - ]

@ TiMRI 4
@ T2MR1
B Models

© skul

© left eyebal

@ right eyeball

@ right optic tract

© left optic nerve

@ optic chiasm

€ right optic nerve

€ left optic tract

© skin
~ [ White matter models
€ left cerebral white matter
@ right cerebral white matter
@ right cerebellar white matter
€ left cerebellar white matter

2

Click the eye icon of the ‘Models’
folder to hide all non-brain
structures.

P @R BA BN BH HR BH BH EH HER

3939399099999

V| Show transforms Show MRML ID's

» Subject hierarchy item information

Filter:
» MRML node information

~ Data Probe

Show Zoomed Slice

B B: T1 MRI
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Volume rendering

(% 3D Slicer 5.0.2 - o x

File Edit View Help

@ @ Modules: 4 | EZ Data = _- G_ O E:f:
) ;

» Help & Acknowledgement

ME- Bmh +-a- @@

Subject hierarchy Transform hierarchy All nodes

Node - E 4 *
¥ Scene
I I S —
@ T2MRI 2
~ | Models @

&

N

© skull - B: T1 MRI
@ left eyeball -

@ right eyeball »

@ right optic tract -

@ left optic nerve -

@ optic chiasm -

€ right optic nerve -

@ left optic tract -

0 skin L

~ 0 NewFolder -
) left cerebral white matter -

€ right cerebral white matter -

@ right cerebellar white matter -

€3 It rerehellar white matter -

V| Show transforms || Show MRML ID's (?)

HEE B EEE
FEREEEEE®

BEBEBG

» Subject hierarchy item information

Filter:
» MRML ng

~ DataPr

Show Zoomed Slice

B B: T1 MRIE
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Display options

5 3D Slicer 5.0.2 — O X
File Edit View Help

E@ @ Modules: -4 | E Data - _. G, O Ea—i
(2] ;

» Help & Acknowledgement

Subject hierarchy Transform hierarchy All nodes

Node
¥ Scene

" T1MRI brain
@ T2MRI

in slice views as foreground

Reset field of view on show

~ [ Models
@ skul 4 Reset view orientation on show
@ left eyeball 4 V| Show in 3D views as volume rendering
@ right eyeball 1 Volume rendering option:
@ right optic tract 1 Show color legend
@ left optic nerve "
@ optic chiasm

€ right optic nerve
@ left optic tract
@ skin

~ [ NewFolder
) left cerebral white matter
€ right cerebral white matter
€ right cerebellar white matter
€D 1ot rershellar white matter

V| Show transforms Show MRML ID's

Right-click the eye icon to
see display options.

FI9393909 99

» Subject hierarchy item information

Filter:

| | Choose ‘Volume rendering
' options...".
: (It switches to the Volume

Rendering module)
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Adjust volume rendering

% 3D Slicer 5.0.2 — O X
File Edit View Help

@ @ Modules: -4 :.YglyrmeRenderripgr Z) -. e_ Q E,,—_E ‘ (4] @ B A [ F - 'IA B e & .%.. v Q v n P

» Help & Acknowledgement

@ vVolume: | T1MRI brain e

> InpUiz

Click on ‘Select a
Preset’ and choose
MR-Default.

~ Di

Renderit

» Adv|

. :. " !"
Ddy Ic{(, L

‘gi){m H\ Adjust the Shift
S \\y /A | slider to optimize
Ty )‘

|/ . V|suaI|zat|on

e
RZ}Q"

4 "? “
ey

~ Data Probe: D:/data/PerkLabBootcamp/...torial_HeadScene.mrml

Show Zoomed Slice

L
F
B
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Show models again

- (] X

+-%- @@

5 3D Slicer 5.0.2
File Edit View Help
@ @ Modules: -4 .Volume Renderir?gr v G. O E_E g 0 % ,,{_ k F - a,'.u J= &
Q;;‘ . Volume Rendering R

Data
» Help & Acknowledgement La Welcome to Slicer ‘h‘

@?“ Turn off volume rendering
~ Display

Preset: | [ MR-Default B - USing the eye iCOn.

Shift:
Crop: Enable 4.k Display RO

Rendering: | VTK GPU Ray Casting

Switch back to the Data
module using the

~ Data Probe: D:/data/PerkLabBootcamp/...torial_HeadScene.mrml

Show Zoomed Slice
L
E
. B: T1 MRI brain
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Show models again

% 3D Slicer 5.02 — O X
File Edit View Help

@ @ Modules: E Data v -. G_ O E
@ 1

» Help & Acknowledgement

[}F'Q".‘ kb&

Subject hierarchy Transform hierarchy All nodes
Node - W & *

¥ Scene
T1MRI brain Sl
@ T2MRI
~ Z Models
© skull
@ left eyeball
@ right eyeball
@ right optic tract
@ left optic nerve
@ optic chiasm
€ right optic nerve
@ left optic tract
@ skin
~ 0 NewFolder
) left cerebral white matter
@ right cerebral white matter
€ right cerebellar white matter
€D |eft rerehellar white matter

v Show transforms Show MRML ID's 1

i

Show the folder again

HEE B =
FEEEEEEEEO

by clicking the closed
eye icon in its row.

9393939099999

HEEEC

» Subject hierarchy item information

Filter:
» MRML node information

~ Data Probe: D:/data/PerkLabBootcamp/...torial_HeadScene.mrml

Show Zoomed Slice
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Change skull model opacity

(% 3D Slicer 5.0.2 — O X
File Edit View Help

@ @ Modules: 4 EDBE >, -. G_ Q E;_E
; 1

» Help & Acknowledgement

VO %

NE_ RN

Subject hierarchy Transfonnhierard’ny | All nodes |

Node - H =
~ Scene
& T1MRIbrain g
@ T2MRI %
~ 7 Models K 3

- 1 e ' NN = Right-C“Ck the eye

nghsm DA O icon of the skull
e model, select Opacity,
e 40w p =*<|and adjust the slicer

P o 5 N . ltoaround 0.30

H H

skin

~ [0 NewFolder
€ left cerebral white matter
€ right cerebral white matter

I EEEREEEEER
[ |
THBEBE

HOE |

@ left optic tract
» Subject hierarchy item information
Filter: |
» MRML node information

~ Data Probe: D:/data/PerkLabBootcamp/...torial_HeadScene.mrml

Show Zoomed Slice

B: T1 MRI brain
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Show axial slice in 3D

5 3D Slicer 5.0.2

Hover the push-pin icon and
then the eye icon to show a

@ @ Modules: 4 jE-tDaté

pEyvee— d slice view in 3D view.

Subject hierarchy | Transform hierardjy al

.
|
»

Node
¥ Scene
& T1MRIbrain
@ T2MRI
~ [ Models
skull
@ left eyeball
@ right eyeball
@ right optic tract
@ left optic nerve
@ optic chiasm
€ right optic nerve
@ left optic tract
skin
~ [ NewFolder
€ left cerebral white matter
€ right cerebral white matter
€ right cerebellar white matter
€D |eft rerehellar white matter

V| Show transforms Show MRML ID's

IEH®
oil:::

FII33099939 938
EETETEEEY
IEERCHEEEEEE B

(i)

» Subject hierarchy item information

Filter:
» MRML node information

~ Data Probe: D:/data/PerkLabBootcamp/...torial_HeadScene.mrml

Show Zoomed Slice

B MRI brain
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Show coronal slice in 3D

% 3D Slicer 5.02 — O X

File Edit View Help

@@ Modules: 4 | EZ Data v | - G O ; 5 Fp "o QF
®

» Help & Acknowledgement

Subject hierarchy Transform hierarchy All nodes

.
|
»

Node
¥ Scene
& T1MRIbrain
@ T2MRI
~ |~ Models
* skull
@ left eyeball
@ right eyeball
@ right optic tract
@ left optic nerve
@ optic chiasm
€ right optic nerve
@ left optic tract
@ skin
~ [ NewFolder
) left cerebral white matter
@ right cerebral white matter
€ right cerebellar white matter
€D |eft rerehellar white matter

V| Show transforms Show MRML ID's (2)

G HH

EE B EEE
FEEEEE®S

¥99390 9993330308y

BEBEBG

» Subject hierarchy item information

Filter:
» MRML node information

~ Data Probe: D:/data/PerkLabBootcamp/...torial_HeadScene.mrml

Show Zoomed Slice

& B: T1 MRI b
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Model clipping

% 3D Slicer 5.0.2 ~ - =

File Edit View Help
@ @ Modules: 4 | F= Data v -. e. O E-E a 0 % & k F . g'? R & ’§« . Q B a a
s 1

» Help & Acknowledgement

Subject hierarchy Transform hierarchy All nodes

Node -~ [l
& T1MRIbrain
@ T2vrI
~ 7 Models
© skull
© left eyebal
@ right eyeball
@ right optic tract
© left optic nerve
& optic chiasm
@ right optic nerve
@ left optic tract
© skin

~ [ NewFold o

2

Right-click a model node in
the data tree and choose
‘Edit properties...” to go to
the Models module.

I I3999999EE

CHAEEEEEEBD

* left oarebral white matter
g Mg | 5 ] (It b d from th
© ro g [y nace .| (It can be accessed fro e
© right ca white matter|  Clone |
i |
© left cerelbemed white matter Delete
Edit ties...
V' Show transforms Show MRML ID' a proertics 9
Convert model to sed
» Subject hierarchy item information L e
xpor ... I I
% il well)
» MRML node information Create child folder

~ Data Probe: D:/data/PerkLabBootcamp/...torial_HeadScene.mrml

Show Zoomed Slice

L
E
B

v ‘:. L} " 3
\ '
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Model clipping

% 3D Slicer 5.02

File Edit View Help

@ @ Modules: 4 | € Models

@

» Help & Acknowledgement

Filter by name...

Node
~ .0 Models
@ skul
@ left eyeball

@ right eyebal
€ right optic tract
@ left optic nerve
@ optic chiasm
@ right optic nerve
@ left optic tract
@ skin
~ [ NewFolder
left cerebral white matter
right cerebral white matter
* right cerebellar white matter
* left cerebellar white matter

» Information

~ Display
v Visibility

-0 E

Select all brain models using
Shift, then scroll down to the
3D Display section.

¥ C 9399

Visibility: v Opacity:

View: All

Show Zoomed Slice

~ Data Probe: D:/data/PerkLabBootcamp/...torial_HeadScene.mrml

B: T1 MRI brain
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Model clipping

5 3D Slicer 5.0.2

File Edit View Help

E@ @ Modules: 4 | € Models

@

@ left optic tract
@ skin
v 7 NewFolder
left cerebral white matter
right cerebral white matter
right cerebellar white matter
left cerebellar white matter

» Information

~ Display
v Visibility

Visibility: V' Opacity:

View: All
Color: [[] #fafae1
~ 3D Display

Representation: | Surface
visble Sides: | Al 2 T1 "R§ (‘9%).
Clipping: Configure...

» Advanced
¥ Slice Display
Visibility: |V
Opacity:

~ Data Probe: D:/data/PerkLabBootcampy. .. torial_HeadScent

Show Zoomed Slice

Laboratory for Percutaneous Surgery — Copyright © Queen’s University, 2022 -43 -




Model clipping

5 3D Slicer 5.0.2
File Edit View Help

@ @ Modules: 4 | @ Models v -. G. o E_,_i g
o

Representation: | Surface

Visible Sides: All

Clipping: v ] Configure...

» Advanced

+ Slice Display

Visbility: v

Opacity: 11100 |5
Mode: Intersection .

Line Width: | 1px
Color Table:

» Scalars

~ Clipping Planes
Clip selected model: v/
Clipping Type: ‘i» Union (@) ) Intersection

( d Slice Clipping: OF- Ot

+ M

o Turn off Red Slice Clipping
( een Slice Clipping: £ positive (® £— Negative and tu rn On Green Slice

p only whole cells when dipping

ta Probe: D:[déta[Perld.abBootcamp/...horia[_HeadScene.mrmI CI i p p i n g .
The optic chiasm becomes

B visible in the 3D view
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3D display options

5 3D Slicer 5.0.2

File Edit View Help

(s
Representation: | Surface
Visible Sides: All
Cipping: v

» Advanced
+ Slice Display

visbility: v

@ @ Modules: -4 | € Models

Configure...

Opacity:

Line Width: | 1px
Color Table:

» Scalars

~ Clipping Planes
Clip selected model: v/

Clipping Type:
Red Slice Clipping:
Yellow Slice Clipping:

V| Green Slice Clipping:

Show Zoomed Slice

L
E
B

Mode: Intersection

Keep only whole cells when dlipping

Seeenenaeeyss L0 display the 3D display

plane.

M Position your cursor over
M the pin icon in the 3D view

I+

options. Select the A
(Anterior) view.

COR
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Save the scene

(% 3D Slicer 5.0.2 - o x
File Edit View Help

@ . Modules: 4 | € Models v -. G. O E.E

Representation: | Surface Click the lsave data’ button.

Visible Sides: All

4 MR- Bah - @@

Clipping: v
» Advanced

+ Slice Display

;7 Note: Also accessible from

Opadity: CaE——

Mode: Inhersection; the File menu

Line Width: | 1px

Color Table:

» Scalars

~ Clipping Planes
Clip selected model: v/

Clipping Type: '3» Union o W) Intersection

Red Slice Clipping: OF-; t
Yellow Slice Clipping: * N %
V| Green Slice Clipping: £ positive O Negative

Keep only whole cells when dlipping

~ Data Probe: D:/data/PerkLabBootcamp/...torial_HeadScene.mrml

Show Zoomed Slice

Laboratory for Percutaneous Surgery — Copyright © Queen’s University, 2022 -46 -




Save the scene

% 3D Slicer 5.0.2
File Edit View Help

BA) ER oo 4 | @woses = 0.Q E o 4

Representation: : Surface - |

———— . The Save Scene and

) Ad

cal B _@ Unsaved Data window lists
oot [ [ | all elements of the scene.

i v WsualizaﬁonTuu:%ﬁdScene.mrb|Medim| Reality Bundle (.mrb) - ‘I‘daiﬁ,’Perld.abBontmmpMsualizaﬁq You Ca n Save as M RB
bundle or as list of files.

Mode

~ Clig
Clip sel

Clipping

= Double-click the scene and
Change directory for selected files A : re n a m e it to
= Z::a Probe: D:/data/PerkLabBootcamp}... torial_HeadScene.mrml | | :{;\ N : my N ews Ce n e ° m r b

Show Zoomed Slice

v Grg

L
E
B

Click Save.
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Close the scene

(% 3D Slicer 5.0.2
Edit View Help
d Data Ctrl+0
| ld DICOM Data
Recent 3

Download Sample Data
24 saveData

"% Close Scene

Exit
» Advanced i. |'

+ Slice Display

Visbiity: v/
Opacity: 1.00 |o

Mode: Intersection v
Line Width: | 1px —

Color Table:

» Scalars

~ Clipping Planes
Clip selected model: v/

Clipping Type: '&_1 Union ° \—?. Intersection
Red Slice Clipping: OF-; .-
Yellow Slice Clipping: * N %

V| Green Slice Clipping: £ positive O Negative

Keep only whole cells when dlipping

~ Data Probe: D:/data/PerkLabBootcamp/...torial_HeadScene.mrml

Show Zoomed Slice
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Load your recently saved scene

ﬁ Save Data
58 Close Scene

(B 3D Slicer 5.0.2

Download Sample Dl

Exit

Clipping Planes

Clipping Type:

Red Slice Clipping:
Yellow Slice Clipping:

Green Slice Clipping:

Keep only whole cells when dipping

- O X

S b F h E|'?.‘

B - @4

C:/Users/pinte/AppData/Local MA-MIC Slicer fcache /SlicerIO MR -hea

Load the new scene using
the Recent data list.
(You can load the scene

Clear History
r-{'] Union ® % Intersection
+ +
* +

+ +

* Data Probe: D:/data/PerkLabBootcamp/.. . torial_HeadScene.mrml

L
E
B

Show Zoomed Slice

using drag&drop or Add
data as well)

= v i [ =———=F—— R:0.0000mm

3
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Thanks for participating!

% 3D Slicer 5.02
File Edit View Help

@ @ Modules: 4 | EE Data - -. G' O E;f—_-
®

» Help & Acknowledgement

Subject hierarchy Transform hierarchy All nodes

Node
¥ Scene
& T1MRIbrain
@ T2MRI
~ [ Models
© skull
@ left eyeball
@ right eyeball
@ right optic tract
@ left optic nerve
@ optic chiasm
€ right optic nerve
@ left optic tract
@ skin
~ [ NewFolder
) left cerebral white matter
@ right cerebral white matter
@ right cerebellar white matter
€D Ieft rerehellar white matter

V| Show transforms Show MRML ID's

BHE |#

FII93930999999939900H
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» Subject hierarchy item information

Filter:
» MRML node information

~ Data Probe

Show Zoomed Slice

F : 13T 0)
B 3: IRI brain
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